Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently December 14 2019, 3:45 AM



Reply to topic  [ 22 posts ]  Go to page Previous  1, 2
 High beam trouble 
Author Message
Forum Moderator
User avatar

Joined: August 10 2005, 10:08 PM
Posts: 6128
Location: Hillsboro, OR
Reply with quote
Post Re: High beam trouble
Your cheapest option would be to just go to the junkyard and find another combination switch... if there are no junkyards, I believe there is a Denmark mx-3 club somewhere, maybe you could post a WTB on there and get one for cheap?

And as far as your relays and such being different, I'm not surprised - the manual is for US spec mx-3's, and you have a euro mx-3. :shrug:

_________________
My Feedback
92 mx-3 gs klze 'race car' IP 15.05 @ 92.5mph
92 mx-3 gs klze 'daily driver' IP 14.55 @ 95.7mph
http://www.cardomain.com/id/Mooneggs
Image


November 24 2009, 12:48 PM
Profile WWW
Regular Member
User avatar

Joined: April 03 2006, 9:48 AM
Posts: 1632
Location: Netherlands
Reply with quote
Post Re: High beam trouble
For that kind of money I'll try myself.

Why don't you go to a junkyard and grab one that is working?

_________________
Just another Mx3 freak :)

Feedback topic: Click

Worklog
Worklog click


November 24 2009, 1:56 PM
Profile WWW
Regular Member

Joined: January 02 2008, 1:18 PM
Posts: 60
Location: Denmark
Reply with quote
Post Re: High beam trouble
yep the cheapest would be a junkyard, but I don't mind the 120$ for a new switch, if I just knew if I can put it on the car, I don't want
to disassemble the switch and have springs and doohickeys jumping out at me :)

It looks simple if you look in the manual, but the part where it says "Don't disassemble the clock spring, because it requires special tools to put it together again"
makes me a bit worried


November 24 2009, 2:39 PM
Profile
Regular Member

Joined: January 02 2008, 1:18 PM
Posts: 60
Location: Denmark
Reply with quote
Post Re: High beam trouble
It was the switch that was bad, bought a used one 80$ so it was okay
now I just need someone to put it in :/


November 26 2009, 11:09 AM
Profile
Regular Member

Joined: January 02 2008, 1:18 PM
Posts: 60
Location: Denmark
Reply with quote
Post Re: High beam trouble
Just realized how easy it is to replace, I tought it was the spring you needed some special tools to install
but it's just a bolt on job, so will replace it tomorrow if I have the time :), maybe take some pictures.
Thanks for the help guys =)


November 26 2009, 2:02 PM
Profile
Regular Member
User avatar

Joined: January 07 2014, 1:58 AM
Posts: 32
Reply with quote
Post Re: High beam trouble
lol post some pictures I need to replace mine, rear wiper is stuck on... how do you know if the airbag is on your model mines a 93 gs. And yes I'm trying to revive this post lol.

_________________
http://www.youtube.com/watch?v=wm-luYeQXU0


January 29 2014, 2:34 AM
Profile WWW
Regular Member

Joined: January 02 2008, 1:18 PM
Posts: 60
Location: Denmark
Reply with quote
Post Re: High beam trouble
I have sold the car, but if it's got an airbag it will say airbag on the steering wheel.

To remove the controls, you just remove the plastic covering around the steering colum, and then remove the control.


January 30 2014, 11:12 AM
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 22 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.