Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently July 04 2020, 12:08 PM



Reply to topic  [ 10 posts ] 
 engine swap problem please help 
Author Message
Junior Member

Joined: April 14 2010, 9:34 PM
Posts: 6
Reply with quote
Post engine swap problem please help
hi iv just done an engine swap on my sisters eunos 30x (mx-3)took out the k8 1.8 and put in a kl i think 2.4 every thing went pritty smooth but it wont start there is no spark. help!!


April 14 2010, 10:21 PM
Profile
Senior Member
User avatar

Joined: August 13 2001, 2:01 AM
Posts: 4476
Location: Atlanta, GA.
Reply with quote
Post Re: engine swap problem please help
The KL and K8 distributors are the same. Try the one from the K8 and see if the one from the KL is bad. Did you change the computer too? If so try he K8 one. It will make the motor run a bit off, but should crank it.

_________________
Image
ZE -strait neck,headers,2.5 exhaust,pheno spacers,lower cross member,GC coils,MS struts,Brembo slotted rotors,filled MS mounts,SS brake/clutch lines, CAI,to rear bat reloc,Hella headlamps,Hella DE fogs 180WHP


April 14 2010, 10:31 PM
Profile
Junior Member

Joined: April 14 2010, 9:34 PM
Posts: 6
Reply with quote
Post Re: engine swap problem please help
thanks ill try the other dizzy . im still running the stock ecu and afm


April 15 2010, 12:52 AM
Profile
Junior Member

Joined: April 14 2010, 9:34 PM
Posts: 6
Reply with quote
Post Re: engine swap problem please help
im also running k8 intake manafold throtle boby ect.
also a plug at the front of the engine maybe crank angle sensor plug on new engine has 3 wires and the car only has 2 ? the temp switch is differant so i changed them. this stuff may not make any differance let me know what you think . thanks


April 15 2010, 1:10 AM
Profile
Junior Member

Joined: April 14 2010, 9:34 PM
Posts: 6
Reply with quote
Post Re: engine swap problem please help
i put the other dizzy on today and it started first go thanks mate.
it idels good but has a flat spot at low revs runs nice at high revs could anyone please help with this.


April 16 2010, 1:23 AM
Profile
Junior Member

Joined: April 14 2010, 9:34 PM
Posts: 6
Reply with quote
Post Re: engine swap problem please help
A BIT MORE INFO


Mazda eunos (mx-3) engine swap

The 1.8 k8 engine broke a conrod and it smashed the crank so i ship in a 2.4 kl ford telstar engine with low k's cost $980 au all up.I left the gearbox in the car and lifted the engine out through the bonnet.i had to stuff around pulling broken bits out of the sump so that i could turn the engine over to losen the converter bolts (auto box).
Had to change the fly wheel because the new one was about 10mm to big. I used the old intake manafold because the trottel body was on a differant angle.I could only get
one bolt in the bracket that bolts the drive sharft to the block but there is room to drill an other hole in it.the pw steer pump/altanator/air con bolted up fine.I had to cut and weld the rear exsurst flange but you could probebley just use the rear manafold off of the old engine im using the stock commputer (ecu) air flow meter and wireing harnes from the
car (k8 1.8 stuff) any way got it all done and it wouldnt start i got on to mx-3 .com and a bloke told me to change over the distributor done that and it started first go it had a ticking sound in it for about 5 minutes and then came good except it has a flat spot when you just touch the excelorator pedal its fine at high revs.


April 16 2010, 6:12 AM
Profile
Junior Member

Joined: April 14 2010, 9:34 PM
Posts: 6
Reply with quote
Post Re: engine swap problem please help
anyone ?????


April 18 2010, 1:23 AM
Profile
Regular Member

Joined: July 06 2008, 1:17 PM
Posts: 44
Reply with quote
Post Re: engine swap problem please help
Let me know when you figure it out :) i think im in the same boat as you. im trying to figure out if theres a common problem between injectors not firing and no spark. I also have a no start after a 92-94 ZE swap-in, the car was running before hand.(mind you lots of problems and codes but still running) now ive fixed everything and it just wont start


June 06 2010, 10:14 AM
Profile
Regular Member

Joined: July 06 2008, 1:17 PM
Posts: 44
Reply with quote
Post Re: engine swap problem please help
I just read that big post and realised you fixed your not start, what are you running a 2.4???? arent they 2.5 ze? anyways check your tp sensor, there usually pretty touchy, and for my problem i have 3 disty, 3 ECU, 3tp and 3 VAF all 1.8 and no0thing starts the car check the other post if you can help :) thanks


June 06 2010, 10:26 AM
Profile
Junior Member

Joined: July 23 2010, 2:34 PM
Posts: 3
Reply with quote
Post Re: engine swap problem please help
I have same problem . and search lot of the sites but still i have not get the answer if any one knoe the answer pleas tell me .

_________________
Debt Help


July 23 2010, 2:56 PM
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.