Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently May 28 2020, 11:26 PM



Reply to topic  [ 23 posts ]  Go to page Previous  1, 2
 The Transition - My MX3 story. 
Author Message
Regular Member

Joined: April 11 2007, 1:39 PM
Posts: 145
Location: Guelph Ontario
Reply with quote
Post Re: The Transition - My MX3 story.
So it was a cold wet morning here today, and the little mazda didn't want to wake up.
It would start but it almost died every time I put my foot on the gas...

Flashing Check Engine Light comes on.

I let it idle for a bit, and it allowed me to move... but put my foot down... and it had nothing...
Let it warm up some more... and it started to drive, but really shitty...
Eventually it warmed up to operating temperature and it was back to normal.

Thoughts? I'm leaning towards electrical, likely the coil or perhaps the distributor cap.


August 19 2014, 11:00 AM
Profile
Supporting Member
User avatar

Joined: July 27 2006, 8:09 PM
Posts: 3774
Location: Chattanooga, TN
Reply with quote
Post Re: The Transition - My MX3 story.
try pulling the codes. sounds like either the distributor or the VAF.

_________________
Bane
'93 Mazda MX-3 ZE
Image
She Hates Me
My For Sale Thread
My Feedback Thread
My GS Worklog Thread


August 20 2014, 2:22 PM
Profile
Regular Member

Joined: April 11 2007, 1:39 PM
Posts: 145
Location: Guelph Ontario
Reply with quote
Post Re: The Transition - My MX3 story.
Yup... Working on that.

Until then, when it's sunny, it drives great. :-)


August 25 2014, 11:38 AM
Profile
Regular Member

Joined: April 11 2007, 1:39 PM
Posts: 145
Location: Guelph Ontario
Reply with quote
Post Re: The Transition - My MX3 story.
The Transition continues!

So, discovering why the engine doesn't like the cold wet weather was an easy task... The coil.

Replaced the coil/distributor and it ran fine... but I was shutting the car down for the winter, and hell knows that I needed another project. It was supposed to be a very simple one.

Update the ignition to an external coil, and add in the MSD 6A Ignition system I had in my old car.

20 minutes with a drill and a new distributor cap, some silver solder and presto... the cap was done!

Now for that MSD unit... well... I'm not sure what vehicle this KLZE was pulled from... the wire colours didn't match any from any MX6, 626, or Millenia. So I went about with Trial and Error.

And Error I did... repeatedly.


May 28 2015, 8:33 AM
Profile
Regular Member
User avatar

Joined: April 03 2006, 9:48 AM
Posts: 1632
Location: Netherlands
Reply with quote
Post Re: The Transition - My MX3 story.
but succeeded?

_________________
Just another Mx3 freak :)

Feedback topic: Click

Worklog
Worklog click


May 28 2015, 1:31 PM
Profile WWW
Regular Member

Joined: April 11 2007, 1:39 PM
Posts: 145
Location: Guelph Ontario
Reply with quote
Post Re: The Transition - My MX3 story.
Just got the TIP3055 connector today.

After work, I'm going to wire it up.
I'm going off of the MSD wiring diagram. Found here: (http://www.pazzer.net/pazzer/served/Files/MSD/MSD_install.gif)

I tried multiple different wiring combinations without the transistor and resistor... all of which caused the car to barely fire or it felt like an anti-theft was kicking in.

Folk'l over at PT had more drawings that supposedly worked... (http://forums.probetalk.com/showthread.php?t=1701116801&page=3)
I'm hoping that my problem is just the transistor... I want this back on the road.


May 29 2015, 8:24 AM
Profile
Regular Member

Joined: April 11 2007, 1:39 PM
Posts: 145
Location: Guelph Ontario
Reply with quote
Post Re: The Transition - My MX3 story.
AND SHE'S ALIVE~!!!

Nothing like tearing out of the driveway to blow the dust off the car, slam on those rusted brakes to 'clean them up' and launch again.

I had forgotten how much fun it is to drive. Small, fast, low... and harsh. Every little bump; but I wouldn't trade it for anything.

What next? Well there is still that 'missing' power since the VRIS timing is off. Anyone have any genius ideas? What EPROM/Computer has the proper VRIS points for the KLZE Curved neck manifold? Remember I've got a OBDII setup.


June 02 2015, 1:31 PM
Profile
Regular Member

Joined: April 11 2007, 1:39 PM
Posts: 145
Location: Guelph Ontario
Reply with quote
Post Re: The Transition - My MX3 story.
So I'm thinking Window switches are going to be the way to go, to time the VRIS points properly.
But... to do that, I'm going to need to dyno test her to see where those cross points happen to lie...

Does anyone know of a place in the Kitchener/Waterloo/Cambridge/Guelph area who has a dyno?


June 05 2015, 9:05 AM
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 23 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.