Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently September 21 2019, 3:57 AM



Reply to topic  [ 31 posts ]  Go to page 1, 2, 3  Next
 My 1st GS Mx-3 
Author Message
Regular Member

Joined: August 27 2006, 12:54 PM
Posts: 74
Location: Spokane Wa
Reply with quote
Post My 1st GS Mx-3
I pickup up a GS Mx3 with a klze swap for $1500 just little bit back. My plans are to paint it, get the proper pieces for the engine, and get a few more OEM pieces to touch it up. Eventually I'll get more pics but for now I mostly am testing if I remember how to do this. https://photos.app.goo.gl/xSsVuXrZQL5a7kov2


Last edited by Eric Hooper on December 16 2017, 10:21 PM, edited 1 time in total.



September 24 2017, 12:52 AM
Profile
Regular Member

Joined: August 27 2006, 12:54 PM
Posts: 74
Location: Spokane Wa
Reply with quote
Post Re: My 1st GS Mx-3
Okay, I remember how to post!. Anyway, I'm not going to paint this car for a long while do to time, cost, and setup reasons but I did need to stop a leaking problem. As many know the sunroof will leak when the drain tubes are clogged which I fixed, but I found a fun side problem with my sunroof: https://photos.app.goo.gl/GmU98fMrYkLVLbmu2


Last edited by Eric Hooper on December 16 2017, 10:45 PM, edited 3 times in total.



September 24 2017, 1:43 AM
Profile
Regular Member
User avatar

Joined: April 03 2006, 9:48 AM
Posts: 1632
Location: Netherlands
Reply with quote
Post Re: My 1st GS Mx-3
Cool you're starting your worklog.

Keep us updated on your progress.

_________________
Just another Mx3 freak :)

Feedback topic: Click

Worklog
Worklog click


September 24 2017, 4:38 AM
Profile WWW
Regular Member

Joined: August 27 2006, 12:54 PM
Posts: 74
Location: Spokane Wa
Reply with quote
Post Re: My 1st GS Mx-3
fixed my images, photobucket and I were having different visions...


September 24 2017, 10:16 AM
Profile
Senior Member
User avatar

Joined: September 10 2001, 2:01 AM
Posts: 8704
Location: Spokane, WA
Reply with quote
Post Re: My 1st GS Mx-3
Welcome back to the forum. I think I remember you-I sold hood from my Mx-3 to you if I'm correct.
My brother was at Pull n save and saw two GS SE's, one on north side and one in east side location-if you're looking some extra parts.

_________________
Magnum s/s lines, strut bars, carbon fiber bezel, indiglow gauge, Sony Xplod, inverted c/f hood, SRD lower tie bar '93 GS SE '95 Cobra SVT #2722 '68 Charger R/T 440
http://www.cardomain.com/id/mitmaks
Image


September 24 2017, 5:33 PM
Profile ICQ YIM WWW
Regular Member

Joined: August 27 2006, 12:54 PM
Posts: 74
Location: Spokane Wa
Reply with quote
Post Re: My 1st GS Mx-3
Yes, that was me. I sold my old one because it was hard to juggle with a starting family, wish I hadn't; but now I can start a new one. sadly my wife thinks she spotted my old mx-3 and it sounds like it's been through some things since I sold it. If I can juggle it I've been wanting to go junkyard crawling so thanks for the heads up.


September 24 2017, 9:34 PM
Profile
Senior Member
User avatar

Joined: September 10 2001, 2:01 AM
Posts: 8704
Location: Spokane, WA
Reply with quote
Post Re: My 1st GS Mx-3
I think I saw $500 GS SE on CL last year or 1.5 years ago. I think it had blown engine but body was solid.

_________________
Magnum s/s lines, strut bars, carbon fiber bezel, indiglow gauge, Sony Xplod, inverted c/f hood, SRD lower tie bar '93 GS SE '95 Cobra SVT #2722 '68 Charger R/T 440
http://www.cardomain.com/id/mitmaks
Image


September 24 2017, 10:09 PM
Profile ICQ YIM WWW
Regular Member

Joined: August 27 2006, 12:54 PM
Posts: 74
Location: Spokane Wa
Reply with quote
Post Re: My 1st GS Mx-3
I got to Pick n Pull to check out those mx-3's and got some good stuff for when I fix it later, in the meantime I have some fairly mild updates. My mx-3 had a double player set up with one playing cds and the other playing cassettes. The cd player didn't work and the cassette player wouldn't show channels so I deleted the cd player and found out that rendered the cassette player useless so one thing led to another and I just got a new head unit. The delete came from a Mazda Protégé, I liked the lid look better.

So, pictures of the simplest thing one can do to a car, stereo install:https://photos.app.goo.gl/CqweprPNaFJhbgUR2

That was going to be all I did to it till at least next year but the car had different plans. I was driving up a hill and suddenly it lost all spark and wouldn't crank, strangely later when my wife tried it the car would crank but there was no spark. I'm thinking cap and rotor or distributor, but I wasn't about to poke the car for hours in front of a strangers house so AAA came to the rescue:

https://photos.app.goo.gl/fCtM3E1X4EUdmrGn1

Now the car's hanging out in the garage and I get to drive the minivan for a few days.

Mitmaks, when I looked there were three. One was a 4cyl with a blown engine for $400, one special edition with random mods for 2,500, and this one with a rather plain listing for $1500. The price was right and it was fairly straight... I wasn't really looking for a KLZE swap so that was icing on the cake. I think if I were to have done the swap I would have gone with the KLDE though for parts availability and ease of getting a matching ECU.

Final picture I have is of the spoiler that was taped on the car that I need to fix:
https://photos.app.goo.gl/Wq2vMGA67GScGKrp2


Last edited by Eric Hooper on December 16 2017, 11:13 PM, edited 1 time in total.



October 05 2017, 12:40 AM
Profile
Regular Member

Joined: August 27 2006, 12:54 PM
Posts: 74
Location: Spokane Wa
Reply with quote
Post Re: My 1st GS Mx-3
I checked the codes and it was throwing 2,17, and 24. I focused on 2 being my reason for no spark since as far as I understand the other two show that I need 02 sensors. The 2 MX-3s were still at the wrecking yard so I grabbed their distributors to try them out. One of the distributors was cracked but I grabbed it anyway and the one I ultimately used was a reman that looked like it had seen some rain. Once the used distributor was installed car started right up so looks like on my list of things to do is complete tune-up and saving for a new distributor.


October 07 2017, 10:57 PM
Profile
Senior Member
User avatar

Joined: September 10 2001, 2:01 AM
Posts: 8704
Location: Spokane, WA
Reply with quote
Post Re: My 1st GS Mx-3
On these cars ignitor goes out and your car won't start, usually when it warms up. New disty fixes problem. You might do a HEI coil mod, bypass stock ignitor.

_________________
Magnum s/s lines, strut bars, carbon fiber bezel, indiglow gauge, Sony Xplod, inverted c/f hood, SRD lower tie bar '93 GS SE '95 Cobra SVT #2722 '68 Charger R/T 440
http://www.cardomain.com/id/mitmaks
Image


October 14 2017, 3:48 PM
Profile ICQ YIM WWW
Regular Member

Joined: August 27 2006, 12:54 PM
Posts: 74
Location: Spokane Wa
Reply with quote
Post Re: My 1st GS Mx-3
Sorry to anyone looking that all my images died. I'll have to figure that out later. I went with a new autozone distributor with a lifetime warranty for $200. Keep my receipt and I should be good to go. I also ended up getting spark plugs, 02 sensors, and spark plug wires from Amazon. So far I've installed everything but the 02 sensors and the car's running quite well. It took me a little while to find out the KLZE takes 2.0l Ford Probe plugs. My idle is still somewhat rough which is probably a mix of the 02 sensors and the K8 ECU. Once I figure out images and get my air compressor working I'm hoping to write a detailed write-up on plastic repair.


October 20 2017, 1:04 AM
Profile
Supporting Member
User avatar

Joined: November 16 2003, 3:01 AM
Posts: 205
Location: Waikato, New Zealand
Reply with quote
Post Re: My 1st GS Mx-3
Eric Hooper wrote:
..... I also ended up getting spark plugs, 02 sensors, and spark plug wires from Amazon. So far I've installed everything but the 02 sensors and the car's running quite well. .....


That is great news. It is always good to see guys looking after the maintenance of the remaining MX-3 survivors. Car looks great.

_________________
Image
Eunos Presso HI-XS Special Edition, KLZE, KL47 IM+TB, MX6 LSD box OEM front s/bar, Outlaw IM+TB thermalbloks, lightened K801 fly, XTD Stage 3 clutch & cover balanced to f/wheel, mbolin tranny saver , walbro 255,short shifter, SRD shifter bushings- H&R Springs and Koni inserts, MSpeed engine mounts, SS brake and clutch lines, PRM CAI,Whiteline rear strut and swaybar, 7x17 Konig/Maxxim Fourteen rims, and stuff.


October 22 2017, 12:34 AM
Profile
Regular Member

Joined: August 27 2006, 12:54 PM
Posts: 74
Location: Spokane Wa
Reply with quote
Post Re: My 1st GS Mx-3
Thanks. I installed the 02 sensors... that was a bit of the adventure. The front sensor was easy but the rear sensor wouldn't budge. After messing with it for an hour I looked at the exhaust connections and decided it was silly to deal with it on the car so I took out the exhaust.

https://photos.app.goo.gl/86slPKQ90Evqpyh23

https://photos.app.goo.gl/7HHdNpMFhxTgLZgo2

With my new found access and a pipe wrench the sensor was out and new in with exhaust re-installed in less time than it took me to blow torch and wd-40 it on the car several times. I took my family on a long drive to another city with a cool park to test the car and it looks like all the cel codes are gone. I think this winter I'm going to park the car in the garage and replace the valve cover and oil pan gaskets as they're leaking quite a bit, and while I'm doing that go over my vacuum hoses. The car starts good but the idle is mildy inconsistent and I'm having a bit of a jerky start when cold. It's also running rich from what I read on the plugs. I think I can get the motor running tip-top fairly easily but it'll just take time, money, and parts.

I hope putting up the image urls works alright. I don't have a paid photo-bucket account so that's why the photos don't always show. Unless I'm not understanding google I can't directly share with it in a post but with the url I believe I can consistently share photos through the link.


October 22 2017, 2:21 AM
Profile
Junior Member
User avatar

Joined: June 14 2015, 8:39 PM
Posts: 13
Reply with quote
Post Re: My 1st GS Mx-3
Did they sensors come out?

_________________
<a href="http://www.freeimagehosting.net/commercial-photography/"><img src="http://i.imgur.com/Ebelrp3.jpg" alt="commercial photography locations"></a>


October 23 2017, 5:59 PM
Profile
Senior Member
User avatar

Joined: September 10 2001, 2:01 AM
Posts: 8704
Location: Spokane, WA
Reply with quote
Post Re: My 1st GS Mx-3
I bought adapter from Harbor Freight tools to remove o2 sensors, works pretty good.

_________________
Magnum s/s lines, strut bars, carbon fiber bezel, indiglow gauge, Sony Xplod, inverted c/f hood, SRD lower tie bar '93 GS SE '95 Cobra SVT #2722 '68 Charger R/T 440
http://www.cardomain.com/id/mitmaks
Image


October 26 2017, 9:40 PM
Profile ICQ YIM WWW
Display posts from previous:  Sort by  
Reply to topic   [ 31 posts ]  Go to page 1, 2, 3  Next

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.