Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently September 21 2019, 3:57 AM



Reply to topic  [ 144 posts ]  Go to page Previous  1 ... 6, 7, 8, 9, 10
 WhiteFinish's Log there we go again 
Author Message
Regular Member
User avatar

Joined: April 03 2006, 9:48 AM
Posts: 1632
Location: Netherlands
Reply with quote
Post Re: WhiteFinish's Log re-installing again.
marcdh wrote:
Great work and perseverance! Keep up the good work.

Thanks Marc :)

DeadMaker wrote:
Do you think zx2 trailing arms are better?
Does it worth?

I don't know yet... car hasn't driven in 5 years :freak:
Even if it would drive soon I couldn't tell you the difference because I don't have a reference anymore.

_________________
Just another Mx3 freak :)

Feedback topic: Click

Worklog
Worklog click


July 16 2015, 11:22 AM
Profile WWW
Regular Member
User avatar

Joined: April 03 2006, 9:48 AM
Posts: 1632
Location: Netherlands
Reply with quote
Post Re: WhiteFinish's Log re-installing again.
The car finally runs (after 5 years )

https://youtu.be/lXsGVBCOqi0


Still some small tweaking left.

_________________
Just another Mx3 freak :)

Feedback topic: Click

Worklog
Worklog click


August 03 2015, 10:04 AM
Profile WWW
Regular Member
User avatar

Joined: April 03 2006, 9:48 AM
Posts: 1632
Location: Netherlands
Reply with quote
Post Re: WhiteFinish's Log re-installing again.
Finally finally finally got my brakes bled !!

It took 4x the conventional way and tried a few times with non-working machines.
Many thanks to my fellow mx3 supporter Sjaak :)

Also installed my seats and the audio

http://youtu.be/0QgTsuTh8qQ

_________________
Just another Mx3 freak :)

Feedback topic: Click

Worklog
Worklog click


August 15 2015, 5:53 PM
Profile WWW
Regular Member
User avatar

Joined: April 03 2006, 9:48 AM
Posts: 1632
Location: Netherlands
Reply with quote
Post Re: WhiteFinish's Log re-installing again.
Car runs, but with a coolant leak. Seems to be coming from the rear head gasket but I'm not sure.

Before I can hit the road this should be solved, as well as my faulty ABS system of which I can't seem to read the codes from. (ABS not working will fail my car for road inspection).

In the meanwhile installed the seals between driveshaft and Astina v6 knuckle.

Image

Image

Some small things for my electrical system of which I wasn't statisfied.
Image

Image

_________________
Just another Mx3 freak :)

Feedback topic: Click

Worklog
Worklog click


September 25 2015, 3:12 PM
Profile WWW
Regular Member
User avatar

Joined: April 03 2006, 9:48 AM
Posts: 1632
Location: Netherlands
Reply with quote
Post Re: WhiteFinish's Log re-installing again.
Found out my short block, rear (right) side isn't flat. Now the head and shortblock don't seal.


Have to tear the engine apart again, deck the shortblock and rebuild :crying:

_________________
Just another Mx3 freak :)

Feedback topic: Click

Worklog
Worklog click


November 01 2015, 4:26 PM
Profile WWW
Regular Member
User avatar

Joined: April 03 2006, 9:48 AM
Posts: 1632
Location: Netherlands
Reply with quote
Post Re: WhiteFinish's Log there we go again
Back to the beginning again.

Engine was leaking coolant from the rear head gasket. Appeared the short blok was slightly bent so it needs resurfacing.
Took the engine apart again.

Image

Image

Image

Image

_________________
Just another Mx3 freak :)

Feedback topic: Click

Worklog
Worklog click


November 08 2015, 5:38 PM
Profile WWW
Regular Member
User avatar

Joined: April 03 2006, 9:48 AM
Posts: 1632
Location: Netherlands
Reply with quote
Post Re: WhiteFinish's Log there we go again
I started rebuilding the block again after the short block has been resurfaced.


In the meanwhile also been very busy with my Mazdaspeed strutbar. It was a bit effected by small corrosion and had some pits in it here and there. That's why I decided to sand everything to make it shiny again.


120-240-320-400-600-800-1000-1200-1500-2000 sanding sanding and sanding.

Image
Image
Image
Image
Image
ImageImage

_________________
Just another Mx3 freak :)

Feedback topic: Click

Worklog
Worklog click


December 26 2015, 6:23 AM
Profile WWW
Regular Member
User avatar

Joined: April 03 2006, 9:48 AM
Posts: 1632
Location: Netherlands
Reply with quote
Post Re: WhiteFinish's Log there we go again
Ok, some updates.

My gearbox is rebuild with the MFactory LSD.

When installing the engine, I mounted the rear enginemount upside down.... damn... crossmember doesn't fit.
Lowered the engine, squeeze in there and fix it.

Hooking up my elektrical, checking for fuel leaks and engine is in the way it should.

Refilling the oil... :freak: A leak !!
Apperently the front valve cover had a broken edge where the gasket sits... Now the valvecover doesn't always seal the engine. Grabbed another one, installed it and called it a day.

So close to having it run again....

_________________
Just another Mx3 freak :)

Feedback topic: Click

Worklog
Worklog click


April 03 2016, 4:57 AM
Profile WWW
Regular Member

Joined: August 07 2010, 11:03 AM
Posts: 155
Reply with quote
Post Re: WhiteFinish's Log there we go again
looking for first onboard :)

_________________
My White JDM MX-3 ZE


April 03 2016, 3:03 PM
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 144 posts ]  Go to page Previous  1 ... 6, 7, 8, 9, 10

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.