Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently November 11 2019, 6:05 PM



Reply to topic  [ 8 posts ] 
 2.5L ECU, 1.8L TCM??? 
Author Message
Supporting Member
User avatar

Joined: November 26 2000, 3:01 AM
Posts: 279
Location: Beverly WV, USA
Reply with quote
Post 2.5L ECU, 1.8L TCM???
Anybody happen to know if a 2.5L ECU from an ATX MX-6 will function correcly with a 1.8L TCM? I've got my 2.5L in and running with the K8 ATX attached...wondering if I can use the 2.5 ECU. I'll post my findings after I try it myself, but was just wondering. Also, if anybody happens to want to help me with the 2.5L ATX wiring in an MX-3, PLEASE DO. The K8 ATX seems have issues.

_________________
1993 MX-3 ~ SE * 2.5L Swap'd
1993 RX-7 ~ Rotary Performance Built
1996 MX-5 ~ M-Edition * Topless, Daily Driver


masonholmes@hotmail.com


January 04 2005, 7:57 AM
Profile WWW
Regular Member
User avatar

Joined: December 28 2001, 3:01 AM
Posts: 761
Location: Christchurch, New Zealand
Reply with quote
Post 
i ran a kf with kf ecu and k8 tcm, it caused the auto to run in safe mode.
i found running the k8 ecu caused it to run way rich, but no trans problems.
i eventually used an afc with the k8 ecu, it worked well, till i killed the tranny (again!)


January 06 2005, 5:31 PM
Profile
Supporting Member
User avatar

Joined: November 26 2000, 3:01 AM
Posts: 279
Location: Beverly WV, USA
Reply with quote
Post 
What does running in safe mode actually mean? Guessing I can't be hurting anything if I'm in a "safe mode". The 2.5 ECU went in lastnight and the engine is running and sounding much healthier - I just have the flashing Hold light and no use of the button itself. As long as I'm not hurting anything, I suppose I could live with this until I get the 2.5 ATX swap figured out - though it would be nice to get it running correctly until then too...

_________________
1993 MX-3 ~ SE * 2.5L Swap'd
1993 RX-7 ~ Rotary Performance Built
1996 MX-5 ~ M-Edition * Topless, Daily Driver


masonholmes@hotmail.com


January 07 2005, 10:52 AM
Profile WWW
Supporting Member
User avatar

Joined: November 26 2000, 3:01 AM
Posts: 279
Location: Beverly WV, USA
Reply with quote
Post 
also, how hard was setting up the AFC, and did the engine run at least as good as with the "correct" ECU?

_________________
1993 MX-3 ~ SE * 2.5L Swap'd
1993 RX-7 ~ Rotary Performance Built
1996 MX-5 ~ M-Edition * Topless, Daily Driver


masonholmes@hotmail.com


January 07 2005, 10:53 AM
Profile WWW
Supporting Member
User avatar

Joined: November 26 2000, 3:01 AM
Posts: 279
Location: Beverly WV, USA
Reply with quote
Post 
Update on the status of my 2.5L ATX MX-3... 2.5 ECU, 2.5 VAF, 1.8 ATCM. I've still got the flashing Hold light and believe have diagnosed the code, or at least what code it's throwing. Code 57, Reduce Torque Signal One. This code is supposed to tell the ECU to retard the engines timing by 6 degrees, in order to keep from frying the ATX. Now...having a 2.5 ECU and 1.8 ATCM running together, (with their possibly slight wiring differences), I'm not sure that this code is actually getting to the ECU or not. If it is, that means I'm losing a good deal of power right there, though I've still got enough to burn both front tires from a stop for three or four feet. Also, for the record, I still have no use of my Hold button on the shifter itself, though the transmission is shifting through all 4 gears just fine, on or off throttle.

_________________
1993 MX-3 ~ SE * 2.5L Swap'd
1993 RX-7 ~ Rotary Performance Built
1996 MX-5 ~ M-Edition * Topless, Daily Driver


masonholmes@hotmail.com


January 13 2005, 12:29 AM
Profile WWW
Regular Member
User avatar

Joined: December 28 2001, 3:01 AM
Posts: 761
Location: Christchurch, New Zealand
Reply with quote
Post 
You might be okay, i didn't want to risk it myself.
Setting up the AFC was real easy and it ran perfectly, it didn't save the tranny in the end tho, towing a horse float killed it proper!!
There's been a couple of others that have tried, but most end up swapping in a manual


January 22 2005, 4:42 AM
Profile
Supporting Member
User avatar

Joined: November 26 2000, 3:01 AM
Posts: 279
Location: Beverly WV, USA
Reply with quote
Post 
still going strong here, though not pulling any horse floats :P and no use of the Hold button. I may temporarily put the 1.8 TCM back in until winter is over, so I can lock it in gears on hills etc.

_________________
1993 MX-3 ~ SE * 2.5L Swap'd
1993 RX-7 ~ Rotary Performance Built
1996 MX-5 ~ M-Edition * Topless, Daily Driver


masonholmes@hotmail.com


January 28 2005, 12:22 AM
Profile WWW
Regular Member
User avatar

Joined: April 29 2006, 6:59 PM
Posts: 1561
Location: Calgary, Alberta
Reply with quote
Post Re: 2.5L ECU, 1.8L TCM???
I'm reviving another dead thread. Being that the ecu has three connectors, is it possible that one of the connectors is transmission related only? Could I somehow utilize both ecus; one to run the engine, the other for the trans?

Just curious.

_________________
Cody
Image


July 23 2013, 9:49 PM
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.