Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently July 10 2020, 5:29 AM



Reply to topic  [ 3 posts ] 
 Intermittent EGR CEL Code B6 DOHC??? 
Author Message
Regular Member

Joined: September 11 2006, 10:22 PM
Posts: 93
Location: Tampa Bay, FL
Reply with quote
Post Intermittent EGR CEL Code B6 DOHC???
Hello all,

My car has been running great ever since I rebuilt it properly and had the ring issue fixed. However, almost every day the CEL will come on until I turn off the car, and the code refers to the EGR system. I don't know where to start looking to fix this issue. Can it be cleaned, or would it be a vaccum leak, or would it be the EGR valve itself needing to be replaced?

Any help is appreciated.

Thanks.

_________________
'94 Mx-3 RS - All Black - Fully Rebuilt B6 DOHC .020 over, CAI, 2 1/4" exhaust, SE Leather Seats, Pioneer DEH-P4000UB, JVC 6.5" in the doors, Rockford Fosgate 400W, 2 12" Dual Subs in Bandpass Box


January 12 2012, 2:31 PM
Profile ICQ YIM
Regular Member

Joined: March 30 2006, 9:55 PM
Posts: 709
Location: Calgary, Alberta
Reply with quote
Post Re: Intermittent EGR CEL Code B6 DOHC???
Usually carbon gums up the diaphragm in the EGR causing it
to stick open / not close properly. Its located at the back
of the engine, just trace the copper tube from the front intake
to the rear.

Two 12mm bolts to remove it IIRC and just spray it with brake cleaner.

Try that and see if it helps clear the CEL

_________________
Image
1994 MX-3 RS
Worklog: viewtopic.php?f=46&t=62251
B6 goodies for sale:
viewtopic.php?f=2&t=66333
2nd BP engine: http://www.clubprotege.com/forum/showthread.php?t=46695


January 12 2012, 3:08 PM
Profile
Regular Member

Joined: September 11 2006, 10:22 PM
Posts: 93
Location: Tampa Bay, FL
Reply with quote
Post Re: Intermittent EGR CEL Code B6 DOHC???
Cleaned it.. There was a ton of carbon buildup, so much that you could scrape it with a screwdriver. Cleaning did not fix it. I just bought and installed a brand new EGR valve and it seemed to run a bit smoother, then after about 30 mins, the code came back. What else should I check?

Thanks

PS, I get 30 mpg average city/hwy (under 60 mph). Seems like I should be getting better with the 1.6 DOHC

My friend's KLZE gets 30 mpg in the same driving conditions.

_________________
'94 Mx-3 RS - All Black - Fully Rebuilt B6 DOHC .020 over, CAI, 2 1/4" exhaust, SE Leather Seats, Pioneer DEH-P4000UB, JVC 6.5" in the doors, Rockford Fosgate 400W, 2 12" Dual Subs in Bandpass Box


May 03 2012, 6:05 PM
Profile ICQ YIM
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.