Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently July 04 2020, 12:36 PM



Reply to topic  [ 8 posts ] 
 no heat 
Author Message
Regular Member
User avatar

Joined: October 13 2011, 3:20 PM
Posts: 186
Location: Lewisburg, PA 17837
Reply with quote
Post no heat
just like the title says the car has next to no heat. I just recently flushed the radiator and heater core and replaced fluids thinking that would fix the lack of heat and still nothing. I have just enough heat in the car to keep in near comfortable with it on full blast and wearing a coat... any suggestions? Blower works great by the way.

_________________
ImageImage

My feedback http://www.mx-3.com/phpBB3/viewtopic.php?f=37&t=78944
My worklog http://www.mx-3.com/phpBB3/viewtopic.php?f=46&t=78228
My want to buy http://www.mx-3.com/phpBB3/viewtopic.php?f=48&t=79033


November 26 2011, 7:40 AM
Profile
Senior Member
User avatar

Joined: October 16 2004, 2:01 AM
Posts: 6289
Location: British Columbia
Reply with quote
Post Re: no heat
Check the coolant level, you proly have air in the system or low coolant. Burp the coolant out while the car is hot with the thermostat open.


November 26 2011, 9:02 PM
Profile
Regular Member
User avatar

Joined: October 13 2011, 3:20 PM
Posts: 186
Location: Lewisburg, PA 17837
Reply with quote
Post Re: no heat
Ill give that a shot solo and ill let you know how it went.

_________________
ImageImage

My feedback http://www.mx-3.com/phpBB3/viewtopic.php?f=37&t=78944
My worklog http://www.mx-3.com/phpBB3/viewtopic.php?f=46&t=78228
My want to buy http://www.mx-3.com/phpBB3/viewtopic.php?f=48&t=79033


November 27 2011, 8:46 AM
Profile
Supporting Member
User avatar

Joined: June 18 2007, 10:51 AM
Posts: 7055
Location: Trenton ON.
Reply with quote
Post Re: no heat
Ya what Jordan said. Try rapidly squeezing the upper rad hose to help burp the system. Sounds to me like there may not be a thermostat in the system. Does the temp gauge go up to where it should?

_________________
2004 Subaru WRX Silver, stage 2, minty interior.
2002 Subaru WRX Blue, SOLD (best E test numbers I've ever seen)
94 MX-6. Sold
92 GS KLZE 5 Speed
96 GS 5 speed, KLZE, Sold
95 GS Minty Shape Sold
92 GS Sold
92 GS Parts Car scrapped.
Feedback viewtopic.php?f=37&t=66348" onclick="window.open(this.href);return false;
7477th member.

I know you believe that you understand what you think I said but I'm sure you realize that what you heard is not what I meant.


November 27 2011, 9:29 AM
Profile
Regular Member
User avatar

Joined: October 13 2011, 3:20 PM
Posts: 186
Location: Lewisburg, PA 17837
Reply with quote
Post Re: no heat
yes the temp gets up to the normal level, and there is indeed a thermostat in the car. In fact I was on the verge of buying a new one that opens up at a higher temp to try to fix the issue anyhow. I do have heat but just enough to defrost the windsheild and to keep the driver and passengers from shivering.

_________________
ImageImage

My feedback http://www.mx-3.com/phpBB3/viewtopic.php?f=37&t=78944
My worklog http://www.mx-3.com/phpBB3/viewtopic.php?f=46&t=78228
My want to buy http://www.mx-3.com/phpBB3/viewtopic.php?f=48&t=79033


November 27 2011, 12:11 PM
Profile
Supporting Member
User avatar

Joined: June 18 2007, 10:51 AM
Posts: 7055
Location: Trenton ON.
Reply with quote
Post Re: no heat
Then it sounds like you need to bring your car to a Rad shop and have them power flush your system. The only other thing I can think of is one of the hoses to your heater core is plugged.

_________________
2004 Subaru WRX Silver, stage 2, minty interior.
2002 Subaru WRX Blue, SOLD (best E test numbers I've ever seen)
94 MX-6. Sold
92 GS KLZE 5 Speed
96 GS 5 speed, KLZE, Sold
95 GS Minty Shape Sold
92 GS Sold
92 GS Parts Car scrapped.
Feedback viewtopic.php?f=37&t=66348" onclick="window.open(this.href);return false;
7477th member.

I know you believe that you understand what you think I said but I'm sure you realize that what you heard is not what I meant.


November 27 2011, 1:14 PM
Profile
Senior Member
User avatar

Joined: October 16 2004, 2:01 AM
Posts: 6289
Location: British Columbia
Reply with quote
Post Re: no heat
Thats what I am thinking too Dan... You could go the ghetto route and unhook the heater core hoses and use a high powered water stream to blow out any s--- stuck in the core..


November 27 2011, 2:38 PM
Profile
Regular Member
User avatar

Joined: October 13 2011, 3:20 PM
Posts: 186
Location: Lewisburg, PA 17837
Reply with quote
Post Re: no heat
So I let the car run with the radiator open for about 10 mins then i started burping the top rad hose... had some bubbles come out, then i stoped the car and went back to tearing my interior out (did a lil painting) and upon reinstallation of everything i started playing with the heat selector on the climate control. After a minute I felt it pop off of something when i pushed it towards heat... so I quickly checked to make sure I did break it an turned the key and cycled the temp.
Sure enough it still worked. After I got done installing everyting the wife and I had to go to the store, When I ran the heat I was scalding hot again.

So I imagine my problem was a combination of a snagged control lever, and air in the system... not really sure though, but as long as the heat works Im happy, Thanks to all who replied so swiftly.

_________________
ImageImage

My feedback http://www.mx-3.com/phpBB3/viewtopic.php?f=37&t=78944
My worklog http://www.mx-3.com/phpBB3/viewtopic.php?f=46&t=78228
My want to buy http://www.mx-3.com/phpBB3/viewtopic.php?f=48&t=79033


November 29 2011, 9:04 AM
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.