Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently July 10 2020, 5:18 AM



Reply to topic  [ 5 posts ] 
 engine searches for idle when messing with the clutch switch 
Author Message
Regular Member

Joined: May 21 2009, 11:19 AM
Posts: 66
Reply with quote
Post engine searches for idle when messing with the clutch switch
so i have been messing with this motor for 2 weeks now. had a mechanic friend over and he was even blown away. its a 94 mazda mx3 1.6l dohc manual trans car and this is what i have figured out so far.

it doesnt throw any codes for the problem so that makes it a pain. once the car warms up and goes into closed loop, it has a problem idling. couldnt drive it without it being in open loop. now i have tried replacing the TPS, Mass Air Flow, blocking off the egr, cleaning the idle air control valve, blocking off the idle air control, spraying starter fluid all over. NOTHING. this is the new thing i found and im like WTF!!!

it was doing this weird idle drop when i pushed in the clutch (very strange) so i disconnected the electric clutch switch that is inner connected to the neutral safety switch and the problem all but went away. so it still has a problem idling and searches for idle but you can actually drive it without any issue in closed loop while the clutch switch is out. every time you pull up to a stop light however, it drops and raises rpms and searches for idle for a moment then levels out.


November 22 2011, 9:40 AM
Profile
Senior Member
User avatar

Joined: April 07 2008, 1:06 PM
Posts: 7198
Location: Manitoba
Reply with quote
Post Re: engine searches for idle when messing with the clutch sw
Readjust your timing, and set your idle a teeny bit higher or lower, depending on where it is now.

Also, check your compression. If the ECU senses the RPM's are falling too low, it bumps the idle. The RPMS could be falling because your compression is bad enough that the motor doesn't make enough power to idle.

_________________
Now with Moderator power!

Black '93 BP RS - wrecked, parted, scrapped.
Green GS - Sold.
Black GS - Summer DD/Race car - Fancy KLZE
Red GS - K8-ATX -> MTX-KLDE - Frakencar. Scrapped
White GS - Rusty. Parts. Scrapped
1997 BMW M3 - my summer baby
2002 BMW 325Xi - sold
2003 Forester Xti - EJ20K swapped.
Feedback


November 22 2011, 10:53 AM
Profile
Regular Member

Joined: May 21 2009, 11:19 AM
Posts: 66
Reply with quote
Post Re: engine searches for idle when messing with the clutch sw
compression is good. i just rebuilt the motor.


November 22 2011, 11:37 AM
Profile
Regular Member

Joined: May 21 2009, 11:19 AM
Posts: 66
Reply with quote
Post Re: engine searches for idle when messing with the clutch sw
the crazy thing is the motor idles just fine when in open loop. i drive it around with the tps unplugged all day long. but when you let it use all the sensors and crap in closed loop, it does this weird idle thing. maybe something with the iac but its not throwing a code?


November 22 2011, 11:38 AM
Profile
Regular Member

Joined: May 21 2009, 11:19 AM
Posts: 66
Reply with quote
Post Re: engine searches for idle when messing with the clutch sw
update. ok so the problem is everytime i put an electrical draw on the system it messes everything up. so when the neutral safty switch turned on, it pulled on the motor, when the lights were on, it pulled even worse, if you had the heater and the lights on the car would idle up and down really bad......but if you unplug the idle air control valve is stopped this.....so when there is something that puts a draw of power on the motor ie heater or headlights, the computer has switches and sensors to read that and to compensate accordingly to try to maintain a decent idle.......heres the big kicker... so if i unplug the iac, then as i turn accessories on, my motor will get pulled on slowly drop down and almost die if you have a bunch of stuff running, BUT if i unplug the connector to the alternator, (not the power wire but the 2 wire plug) and have the iac unplugeed, then the car runs just fine. PERFECT EVEN. maybe voltage regulator???


November 22 2011, 12:21 PM
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.