Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently July 04 2020, 10:36 AM



Reply to topic  [ 4 posts ] 
 BP not turning on 
Author Message
Regular Member

Joined: July 17 2011, 3:10 AM
Posts: 48
Location: Somewhere in Texas
Reply with quote
Post BP not turning on
i just installed my BP engine from a 1991 protege lx into my 1995 mx3 i dont understand why it wont turn on i have fuel and i have spark and its on time it should turn on any ideas?


October 13 2011, 8:31 PM
Profile
Regular Member

Joined: May 19 2008, 3:54 PM
Posts: 363
Location: Ravensdale WA 98051
Reply with quote
Post Re: BP not turning on
When you turn the key, does everything power up?
Double check every wire, the neutral switch on your transmission would cause the engine to not turn.
Turn the key without trying to start it and listen for the fuel pump?
The ECU plugged in all the way?

If it is turning over and not starting, check the fuel lines (I once put them on backwards)
Again, check all the wiring connections.
Timing off? Align all the marks and distributor.
When doing your timing belt, make sure you do the 1-5/6 turn step. It really does need to be done.

There are so many ways a swap can go bad. Double check everything.

_________________
Wings on an MX3? What are you thinking?

92 RS BP05
93 GS KLZE
(Previously owned by 2Fazed and then mrMazda92)


January 07 2012, 8:30 PM
Profile YIM
Supporting Member
User avatar

Joined: June 18 2007, 10:51 AM
Posts: 7055
Location: Trenton ON.
Reply with quote
Post Re: BP not turning on
Check that there's no plug left undone. Are the tranny plugs plugged in like?

_________________
2004 Subaru WRX Silver, stage 2, minty interior.
2002 Subaru WRX Blue, SOLD (best E test numbers I've ever seen)
94 MX-6. Sold
92 GS KLZE 5 Speed
96 GS 5 speed, KLZE, Sold
95 GS Minty Shape Sold
92 GS Sold
92 GS Parts Car scrapped.
Feedback viewtopic.php?f=37&t=66348" onclick="window.open(this.href);return false;
7477th member.

I know you believe that you understand what you think I said but I'm sure you realize that what you heard is not what I meant.


January 07 2012, 8:38 PM
Profile
Senior Member
User avatar

Joined: December 30 2008, 4:41 AM
Posts: 2504
Location: Calgary, Alberta, Canada
Reply with quote
Post Re: BP not turning on
check your engine fuse, IIRC mx3 is 10amp and BP is 15amp

_________________
Worklog: viewtopic.php?f=46&t=70628

Image


January 08 2012, 12:32 AM
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.