Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently July 12 2020, 9:16 AM



Reply to topic  [ 18 posts ]  Go to page 1, 2  Next
 need advice please help !! 
Author Message
Regular Member

Joined: January 05 2010, 4:48 AM
Posts: 47
Reply with quote
Post need advice please help !!
i have a 96 RS DOHC!! i fried my ecu.. the code on it is B6DE and my car has been sitting all summer because i cannot find one at any wreckers around here.. someone told me that some ecu's from other cars can work for my car... my question is.. wich car,make,model would work for mine.. thanks in advance for helping


September 23 2011, 6:24 PM
Profile
Senior Member
User avatar

Joined: April 07 2008, 1:06 PM
Posts: 7198
Location: Manitoba
Reply with quote
Post Re: need advice please help !!
The one I have in my basement will work for you.

$20 plus S&H?

The 94+ MX-3 RS was the only one with that exact motor.

_________________
Now with Moderator power!

Black '93 BP RS - wrecked, parted, scrapped.
Green GS - Sold.
Black GS - Summer DD/Race car - Fancy KLZE
Red GS - K8-ATX -> MTX-KLDE - Frakencar. Scrapped
White GS - Rusty. Parts. Scrapped
1997 BMW M3 - my summer baby
2002 BMW 325Xi - sold
2003 Forester Xti - EJ20K swapped.
Feedback


September 23 2011, 6:29 PM
Profile
Regular Member

Joined: January 05 2010, 4:48 AM
Posts: 47
Reply with quote
Post Re: need advice please help !!
its B6GD my bad!!!


September 23 2011, 8:42 PM
Profile
Senior Member
User avatar

Joined: April 09 2007, 1:26 PM
Posts: 2400
Location: Calgary, AB
Reply with quote
Post Re: need advice please help !!
take a pic and post it. It's probably an OBDII ecu. Is it 4 plug?


September 23 2011, 8:58 PM
Profile
Regular Member

Joined: January 05 2010, 4:48 AM
Posts: 47
Reply with quote
Post Re: need advice please help !!
gonna need a crash course on putting pics lol.. it is obdII because i scanned it a fieu times with the one i bought from crappy tire.. it has 3 plugs .. kept blowing my engine fuse like it was going out of style just by turning the key and pushing the clutch in... fried a fieu wires suprised has not caught on fire... opened the computer up to notice she was toast.. so i wanna circle the problem before putting a new one in since i have such a hard time to find one.. i have gone to pick and pull kelowna.calgary..here in edmonton and sweet nothing a guy at the front desk said that mazda 323 and protege has the same but havent found anything.. i love this car and dont feel like i should give up on her just yet..


September 23 2011, 9:45 PM
Profile
Senior Member
User avatar

Joined: April 07 2008, 1:06 PM
Posts: 7198
Location: Manitoba
Reply with quote
Post Re: need advice please help !!
viewtopic.php?f=21&t=65552

Rule #1 of Pick'n'Pull's is never trust the employees to know ANYTHING specific about cars.

Seriously, trust us.

_________________
Now with Moderator power!

Black '93 BP RS - wrecked, parted, scrapped.
Green GS - Sold.
Black GS - Summer DD/Race car - Fancy KLZE
Red GS - K8-ATX -> MTX-KLDE - Frakencar. Scrapped
White GS - Rusty. Parts. Scrapped
1997 BMW M3 - my summer baby
2002 BMW 325Xi - sold
2003 Forester Xti - EJ20K swapped.
Feedback


September 23 2011, 11:19 PM
Profile
Regular Member

Joined: January 05 2010, 4:48 AM
Posts: 47
Reply with quote
Post Re: need advice please help !!
Image where my thumb is it has nothing to connect to ...


Last edited by gxser on September 24 2011, 12:47 AM, edited 2 times in total.



September 24 2011, 12:38 AM
Profile
Regular Member

Joined: January 05 2010, 4:48 AM
Posts: 47
Reply with quote
Post Re: need advice please help !!
http://i1084.photobucket.com/albums/j42 ... 000172.jpg better view of the unit with paint peeled off still can kinda tell what it is


Last edited by gxser on September 24 2011, 12:50 AM, edited 1 time in total.



September 24 2011, 12:40 AM
Profile
Regular Member

Joined: January 05 2010, 4:48 AM
Posts: 47
Reply with quote
Post Re: need advice please help !!
Image this is the mess i am in right now.. due to melted wires had to rip it all off to get to it ...


September 24 2011, 12:42 AM
Profile
Regular Member

Joined: January 05 2010, 4:48 AM
Posts: 47
Reply with quote
Post Re: need advice please help !!
Ryan wrote:
http://www.mx-3.com/phpBB3/viewtopic.php?f=21&t=65552

Rule #1 of Pick'n'Pull's is never trust the employees to know ANYTHING specific about cars.

Seriously, trust us.

thanks for the crash course and advice :)


September 24 2011, 12:51 AM
Profile
Regular Member

Joined: March 06 2007, 2:17 PM
Posts: 1603
Location: Pittsburgh, Pennsylvania (USA)
Reply with quote
Post Re: need advice please help !!
You just inadvertedly helped me trace the interior wiring.

I did NOT know it travles that far up in the dash :shock:


September 24 2011, 5:09 PM
Profile
Regular Member

Joined: January 05 2010, 4:48 AM
Posts: 47
Reply with quote
Post Re: need advice please help !!
i found a parts car a 94!! i wonder if i changed the whole harness if it would work on my 96? did they change much between these years if anyone knows thanks in advance....


September 26 2011, 2:19 AM
Profile
Senior Member
User avatar

Joined: April 07 2008, 1:06 PM
Posts: 7198
Location: Manitoba
Reply with quote
Post Re: need advice please help !!
Yes, 94 was a bastard child, and OBDII started in 95.

_________________
Now with Moderator power!

Black '93 BP RS - wrecked, parted, scrapped.
Green GS - Sold.
Black GS - Summer DD/Race car - Fancy KLZE
Red GS - K8-ATX -> MTX-KLDE - Frakencar. Scrapped
White GS - Rusty. Parts. Scrapped
1997 BMW M3 - my summer baby
2002 BMW 325Xi - sold
2003 Forester Xti - EJ20K swapped.
Feedback


September 26 2011, 11:09 AM
Profile
Regular Member

Joined: January 05 2010, 4:48 AM
Posts: 47
Reply with quote
Post Re: need advice please help !!
ok so ii got the harness and ecu from a 96 but my ecu has diferent code on it mine SAYS remanufactured B6GD and this one is just B6GD i put that in with the harness , but now the freakin thing wont start it turns over fine but i have no spark. the fuel pump will not kick in.. and my engine light will not turn on .. i had the similar problem before it was the engine fuse .. i changed the ignition switch. i have no idea what to do now any help would be great thanks in advance


November 29 2011, 7:57 PM
Profile
Senior Member
User avatar

Joined: April 07 2008, 1:06 PM
Posts: 7198
Location: Manitoba
Reply with quote
Post Re: need advice please help !!
Dear lord. I remember this.

Poor guy, thats a horrible mess.

So you put a new 96 harness into the 96 car with a 96 ECM, and no go?


No fuel pump kickining in means that you're not getting the signals from the disty. Check between your harnesses that the distributor pins are correct, that is, each pin on the disty harness traces back to the same pin on the ECM between the harnesses.... follow?

Aside from that, if your new harness is indeed good, its just a matter of tracing it all back... start with looking for 12v and ground at the disty.

Did you ground the ECM properly? This is important, or you might cook it.

_________________
Now with Moderator power!

Black '93 BP RS - wrecked, parted, scrapped.
Green GS - Sold.
Black GS - Summer DD/Race car - Fancy KLZE
Red GS - K8-ATX -> MTX-KLDE - Frakencar. Scrapped
White GS - Rusty. Parts. Scrapped
1997 BMW M3 - my summer baby
2002 BMW 325Xi - sold
2003 Forester Xti - EJ20K swapped.
Feedback


November 29 2011, 10:43 PM
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 18 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.