Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently November 13 2019, 5:18 AM



Reply to topic  [ 3 posts ] 
 Cone filter install write up (56k warning) 
Author Message
Regular Member
User avatar

Joined: February 13 2005, 1:15 PM
Posts: 321
Location: Sparks, NV in the USA
Reply with quote
Post Cone filter install write up (56k warning)
This subject has been brought up time and time again, with sometimes unclear help leading to frustration among members. To end all frustrations and make things simple for new members I offer this complete write up on how to install a cone filter on your MAF sensor (94-95 RS). I will do a write up for an ebay intake within the month hopefully. Here goes.

Image

This picture shows what parts are involved in your stock intake system. All these parts can be removed, but most are optional to you. If you can't find any of them or this picture confuses you, just close you hood and go back in the house :wink:

Image

After removing your factory airbox, loosening the hose clamp that connects the MAF and the Throttle Body, and removing the electrical connector, your MAF should be free. This is what it looks like laying on your living room floor.

Image

This is a side view of your MAF. There is a rubber ring where the factory airbox used to attatch to it. Just pull that off to give yourself a better mounting surface for your filter. (I didn't with my first filter, and it ended up falling off on the freeway and shooting out the bottom of my car like a rocket...)

Image

Pic with that rubber ring removed.

Image

You're ready to attatch your cone filter. I'm using a K&N filter with a 3.5in opening. That's the normal size for filters you see at Pepboys, Autozone, real performance shops, etc... etc... They should all work.

Image

Pic with filter installed, tightened down and ready to rock. See? It works. I'm not lying to you lol. And this thing ain't going no where.

Image

This is how it looks installed on the car. Stick your MAF back in intake tube and tighten the clamp down best you can with out stripping the screw. Nothing supports mine, it just hangs there. Probably not the best method, but it works for me til I get a real intake. You might try to figure out some way to support it.

_________________
It might be slow, but it's not a civic!


Last edited by freyguy_412 on November 17 2005, 4:37 PM, edited 1 time in total.



November 16 2005, 3:22 AM
Profile YIM WWW
Regular Member
User avatar

Joined: October 29 2002, 3:01 AM
Posts: 1778
Location: San Antonio TX
Reply with quote
Post 
Well said and put in pic. verse words good :idea:

_________________
(12.4@118@18psi) 92 MX-3, KIA (BP-DE)Swap, Electromotive TEC II Standalone, 8,200 Rev Limit, Custom Intake/Exhaust Manifold, 1,000cc PTE Injectors, Custom Fuel Rail, Aeromotive FPR, 80MM Holley TB, MSD 8.5MM Wires, NGK V-Power #8, SC6262 Turbo, 3 in. DownPipe, Tial WG/BOV, 600HP PTE FMIC, 2.5IN Intercooler Piping, EQUUS/Autometer KIA G-Series Tran, Extreme ACT Clutch, Built BP in starting process.


November 16 2005, 3:39 AM
Profile YIM
Site Administrator
User avatar

Joined: November 07 2000, 3:01 AM
Posts: 8391
Location: Lat 35.1N Lon -90W
Reply with quote
Post 
Nice write up

Moved to the FAQ!

_________________
Keep this site alive! Donate!


November 16 2005, 11:08 AM
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.