Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently January 21 2020, 8:04 PM



Reply to topic  [ 7 posts ] 
 Gs fuel pump changed getting gas no start problem 
Author Message
Junior Member

Joined: January 24 2014, 8:14 PM
Posts: 21
Location: Louisiana
Reply with quote
Post Gs fuel pump changed getting gas no start problem
Ok so car been running fine no issues well Friday I get home kill it and go back later to start and crank but no ignition after 2 days of looking tracing relays and fuel pump replacement I figure out that it's the fuel pump connector on the sending unit so being I can't get a mx3 down in the south I've had to improvise found a sending unit out of a protege has the same plug and all as the mx3 on the sending unit well should I mention the connection in the sending unit to the fuel pump was burnt so replaced and after some mods I'm getting fuel to the front now the hard part still not starting I have not changed anything or done anything to it but try to start I checked plugs for fire they have fire checked the line going into the pressure regulator and it has fuel next issue I heard is a ticking noise fron the throttle body so after longer inspection I unplug the throttle position sensor and it stops I just replaced the throttle position sensor a couple months ago could this be my starting problem? I thought the tps sensor regulated air not fuel? Pulled codes and get egr valve something I been working on and knock sensor. I'm ata standstill on this ATM. Don't wanna replace any unnecessary parts but need my car any suggestions would be greatly appreciated thanks


August 11 2014, 10:41 AM
Profile
Regular Member

Joined: January 15 2008, 7:45 PM
Posts: 551
Location: Twin Cities, MN
Reply with quote
Post Re: Gs fuel pump changed getting gas no start problem
Fuel flow is one way. Supply from the pump must go directly to the fuel rails (not through the regulator). The fuel pressure regulator (FPR) is actually on the return line. If you disconnect the line attached to the FPR then fuel should come out of the fuel rail NOT the fuel line. I believe you have fuel lines crossed.

Switch the fuel lines at the pump and see if that helps.

_________________
Image
Proud owner of a Faded Red 92 MX-3 GS


August 11 2014, 11:45 AM
Profile
Junior Member

Joined: January 24 2014, 8:14 PM
Posts: 21
Location: Louisiana
Reply with quote
Post Re: Gs fuel pump changed getting gas no start problem
Ok thanks gonna try that now thanks will update if that works


August 11 2014, 12:06 PM
Profile
Junior Member

Joined: January 24 2014, 8:14 PM
Posts: 21
Location: Louisiana
Reply with quote
Post Re: Gs fuel pump changed getting gas no start problem
Thanks guys somewhere in the confusion the pump was hooked up backwards and the lines to the fuel rail were crossed but got it fixed and running now thanks for all your help


August 11 2014, 1:05 PM
Profile
Supporting Member
User avatar

Joined: June 18 2007, 10:51 AM
Posts: 7055
Location: Trenton ON.
Reply with quote
Post Re: Gs fuel pump changed getting gas no start problem
We should have a post for everyone who's ever connected those damn lines bckwards. :lol: Of course I never did,,, :oops: :D

_________________
2004 Subaru WRX Silver, stage 2, minty interior.
2002 Subaru WRX Blue, SOLD (best E test numbers I've ever seen)
94 MX-6. Sold
92 GS KLZE 5 Speed
96 GS 5 speed, KLZE, Sold
95 GS Minty Shape Sold
92 GS Sold
92 GS Parts Car scrapped.
Feedback viewtopic.php?f=37&t=66348" onclick="window.open(this.href);return false;
7477th member.

I know you believe that you understand what you think I said but I'm sure you realize that what you heard is not what I meant.


August 13 2014, 12:29 PM
Profile
Supporting Member
User avatar

Joined: July 27 2006, 8:09 PM
Posts: 3774
Location: Chattanooga, TN
Reply with quote
Post Re: Gs fuel pump changed getting gas no start problem
I do it myself as well...

50/50 chance of getting it right translates into 100%, "You're gonna get it wrong."

_________________
Bane
'93 Mazda MX-3 ZE
Image
She Hates Me
My For Sale Thread
My Feedback Thread
My GS Worklog Thread


August 13 2014, 12:32 PM
Profile
Regular Member
User avatar

Joined: December 29 2013, 11:16 AM
Posts: 119
Location: N.C.
Reply with quote
Post Re: Gs fuel pump changed getting gas no start problem
I drew a silver arrow with a paint pen on my tubes :D if I still get them wrong you guys can officially call me a wannabe mechanic :freak:

_________________
93 MX3 SE (klze conversion in progress)
03 Elantra GLS (DD)
92 MX3 GS sold :( missed!
The very air around me seemed to catch fire and freeze at the same time, that's how I knew he had enough for today.
Rangers Lead The Way!


August 14 2014, 6:48 AM
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.