Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently December 10 2019, 8:28 PM



Reply to topic  [ 8 posts ] 
 emissions woes 
Author Message
Regular Member

Joined: February 05 2014, 7:33 PM
Posts: 87
Reply with quote
Post emissions woes
My car is having a hard time passing smog.. It goes like this..
Everything the same as the day I bought it except the throttle body.. I drove it around for a half hour..
took it to the smog place and the car blew the test at idle

1st try numbers:
@900 rpm
idle speed test(no revving)
max allowed: HC 220 ppm
mazda: HC 331 ppm
Result: FAILED

I figured the idle was too high.. went home and tightened the air adjust screw while the TEN+GND jumped had the idle settled further down

went back next day

@780 rpm according to the guys inductor
idle speed test
mazda: 301 ppm

I figured I was on to something since lowering the idle made the HC lower.
Did some research and found HC is basically unburned fuel.
All smog tip websites suggest ignition parts with tune up..
No big deal since I don't the history of the car.. I went ahead and timed the car 10* btdc
changed the spark plugs and ignition rotor. cap looked alright.
changed the oil. Car sounds good HLA tick when cold is gone..
I drove the car about 30 minutes..

3rd try

@670 rpm according the machine
idle speed test
mazda: 449 ppm
WORSE! The car is running better and quieter. Has more power than when I first got and I can't get this damn thing to pass.


February 22 2014, 2:18 AM
Profile
Regular Member

Joined: September 03 2006, 10:29 PM
Posts: 605
Location: Langley, BC
Reply with quote
Post Re: emissions woes
You need pre cat testing with a gas anylizer to confirm the state of health of your cat...

There is a good chance though your tps is out of adjustment... This won't allow the car to enter proper fuel control at idle... it causes high hc and usually Co readings...

You need to set your idle back to stock properly and recheck cat health and tps adjustment


February 22 2014, 2:43 AM
Profile
Regular Member

Joined: February 05 2014, 7:33 PM
Posts: 87
Reply with quote
Post Re: emissions woes
woops forgot to mention I adjusted the TPS with a feeler. All within spec per Daninski's instruction.. so throw a new cat on?


February 22 2014, 12:55 PM
Profile
Regular Member

Joined: September 03 2006, 10:29 PM
Posts: 605
Location: Langley, BC
Reply with quote
Post Re: emissions woes
zerialz wrote:
woops forgot to mention I adjusted the TPS with a feeler. All within spec per Daninski's instruction.. so throw a new cat on?


Can't tell you the ccat is dead with out proper testing...you can keep throwing parts at it or you can have someone pproperly diagnose it...

it's possible the thermostat is stuck open and the car isn't warming up causing it to stay in open loop... or even a bad coolant temp sensor. ..could be burning oil.. but once again you need proper pre cat readings with a gas anilizer. ...


February 22 2014, 9:19 PM
Profile
Regular Member

Joined: February 05 2014, 7:33 PM
Posts: 87
Reply with quote
Post Re: emissions woes
I guess I'll take it to guys I brought my probes to.. whenever I got tired of messing with them..


February 22 2014, 9:43 PM
Profile
Regular Member

Joined: February 05 2014, 7:33 PM
Posts: 87
Reply with quote
Post Re: emissions woes
It was the cat.


March 04 2014, 2:52 PM
Profile
Senior Member

Joined: October 17 2004, 2:01 AM
Posts: 2220
Location: SLC, Utah
Reply with quote
Post Re: emissions woes
how do you know it was the cat?
Did you have it tested?

I'd hate for you to have to replace a cat again next year

_________________
2008 Mazda 3
1993 MX3 GS
KLZE, Fidanza flywheel, KL31 CAMs, South Bend Stage I Clutch, Pacesetter STS, SS AutoChromes, Magnaflow muffler, 2.25' Exhaust, CAI, Blaster Coil HEI, KLDE Valvetrain, 5 Speed Swap


March 05 2014, 12:42 AM
Profile
Regular Member

Joined: February 05 2014, 7:33 PM
Posts: 87
Reply with quote
Post Re: emissions woes
It was tested with a new cat and passed instantly. the pre-existing cat looked marginally aged but, the car did come with a throttle body issue.. I'm changing to royal purple next interval with new ngk wires.. in the next week or two I'll change the IM and VC gaskets..


March 05 2014, 2:06 AM
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.