Donate to the MX-3.com Forums
View unanswered posts | View active topics It is currently December 07 2019, 5:31 AM



Reply to topic  [ 31 posts ]  Go to page 1, 2, 3  Next
 KLZE swap, some issues off the bat 
Author Message
Regular Member

Joined: March 07 2013, 9:50 PM
Posts: 70
Reply with quote
Post KLZE swap, some issues off the bat
I put a ZE in my 92 GS. I'm getting idle problems, which require me to press the gas when I fire it back up unless I sit for a while... as soon as it warms up it basically just stalls. It fires back up no problem as long as I'm pushing the gas. Some things I feel the need to mention, not that I know anything...
Rear o2 sensor is unplugged.
Running stock ECU.
Problem started after I put gas in it. It had old 87 as was doing fine. I added two gallons of 89 right before it started.

Any ideas on what to start looking for?

Also, no speedo. Did I just miss a plug on the tranny?

_________________
92 MX-3 ZE "The draggin' wagon"
Colt cams and bolt-ons


January 29 2014, 4:35 PM
Profile
Regular Member
User avatar

Joined: November 02 2012, 8:40 AM
Posts: 371
Location: Troy, VT
Reply with quote
Post Re: KLZE swap, some issues off the bat
You mentioned in an earlier post you had found the problem to be a vacuum leak, what happened??

_________________
Work Log: http://mx-3.com/phpBB3/viewtopic.php?f=46&t=80716


January 29 2014, 4:42 PM
Profile
Regular Member

Joined: March 07 2013, 9:50 PM
Posts: 70
Reply with quote
Post Re: KLZE swap, some issues off the bat
Plugged the larger nipple. Plugged the small line going in after the JE50. After that it held a stable idle all the way up to temp, the wheels spun... up off the ground. After some revving it still held fast and successfully hunted for idle. Idk wtf happened. My friend suggested water, possibly. To also note it doesn't hold perfect idle. I sounds like it misses a fire intermittently a couple times a second. No rythym to the misses.

_________________
92 MX-3 ZE "The draggin' wagon"
Colt cams and bolt-ons


January 29 2014, 4:52 PM
Profile
Regular Member

Joined: January 15 2008, 7:45 PM
Posts: 551
Location: Twin Cities, MN
Reply with quote
Post Re: KLZE swap, some issues off the bat
I'll take the easy one. The speed sensor is on the top of the differential toward the passenger side axle. So, back of engine, near firewall as far right as you can go and still be part of the transmission. It is a 2 wire plug. The speed sensor is a driven gear and electronics on top held in place by a bolt.

_________________
Image
Proud owner of a Faded Red 92 MX-3 GS


January 29 2014, 8:15 PM
Profile
Regular Member

Joined: January 15 2008, 7:45 PM
Posts: 551
Location: Twin Cities, MN
Reply with quote
Post Re: KLZE swap, some issues off the bat
Misfire: Look at the obvious suspects like spark plugs, wires, distributor cap and rotor. If all that is new then a question: What distributor are you using? I believe the key is to use a matching set of ECU, distributor and MAF.

IIRC another post you set TPS by fan method. If you want perfect idle you need to break out a multi-meter and feeler gauge. Follow the manual to set TPS position. However TPS position doesn't explain misfire. See service manual section - page: F2-152 and a few pages.

_________________
Image
Proud owner of a Faded Red 92 MX-3 GS


January 29 2014, 8:25 PM
Profile
Regular Member

Joined: March 07 2013, 9:50 PM
Posts: 70
Reply with quote
Post Re: KLZE swap, some issues off the bat
That voltometer technique is a touchy subject on MX6.com!
It's not the TPS, I've had failed TPS-s before and it's not like this. I'm gonna take absolute easiest way out first and run dry gas tomorrow.

I'm running an American DE disty with the HEI and coil setup.

Misses aside, the need to give it gas to sustain idle draws me to a fuel based inference. Shitty idle>no idle. It does sound like the ignition system could use some attention, and I will get to that this week.

_________________
92 MX-3 ZE "The draggin' wagon"
Colt cams and bolt-ons


January 29 2014, 9:49 PM
Profile
Supporting Member
User avatar

Joined: June 18 2007, 10:51 AM
Posts: 7055
Location: Trenton ON.
Reply with quote
Post Re: KLZE swap, some issues off the bat
You should adjust the idle screw on top of the disty. Get a RPM gauge, don't use the tach on the dash, then screw the screw in and out till the RPM is at 650 (about 3 turns out). This adjustment as well as your timing is done with TEN and Gnd jumped in the diagnostics box. The RPM will go to 700 once you remove the jumper in the box (can use cotter pin to jump).
If the idle problem started after adding gas you may have crap in your fuel tank and your fuel filter is plugging up.

_________________
2004 Subaru WRX Silver, stage 2, minty interior.
2002 Subaru WRX Blue, SOLD (best E test numbers I've ever seen)
94 MX-6. Sold
92 GS KLZE 5 Speed
96 GS 5 speed, KLZE, Sold
95 GS Minty Shape Sold
92 GS Sold
92 GS Parts Car scrapped.
Feedback viewtopic.php?f=37&t=66348" onclick="window.open(this.href);return false;
7477th member.

I know you believe that you understand what you think I said but I'm sure you realize that what you heard is not what I meant.


January 30 2014, 10:10 AM
Profile
Regular Member
User avatar

Joined: November 02 2012, 8:40 AM
Posts: 371
Location: Troy, VT
Reply with quote
Post Re: KLZE swap, some issues off the bat
Idle screw is located on top of the throttle body not the distributor.

_________________
Work Log: http://mx-3.com/phpBB3/viewtopic.php?f=46&t=80716


January 30 2014, 11:37 AM
Profile
Regular Member
User avatar

Joined: June 21 2010, 1:27 PM
Posts: 542
Location: Picton
Reply with quote
Post Re: KLZE swap, some issues off the bat
if im not mistaken the screw on the TB isn't the idle that's the air control screw. idle screw is on the side of the TB where the accelerator cable is.
could be gas related the type of gas, I know if I use 89 in mine my car runs like a bag of rocks, starts and stalls has no power, once I put in 91 she runs like a charm.

_________________
Own
1994 MX-3 GS swapped ZE
1994 MX-3 GS Swapped ZE (Gone)
1996 Dodge Dakota Sport v8 Magnum
2007 Ford Fusion SE

WORK LOG: viewtopic.php?f=46&t=81232
Image

My MX-3 is nothing without me, and i am nothing without my MX-3


January 30 2014, 2:20 PM
Profile YIM WWW
Regular Member
User avatar

Joined: November 02 2012, 8:40 AM
Posts: 371
Location: Troy, VT
Reply with quote
Post Re: KLZE swap, some issues off the bat
mazdaspeed23 wrote:
if im not mistaken the screw on the TB isn't the idle that's the air control screw. idle screw is on the side of the TB where the accelerator cable is.
could be gas related the type of gas, I know if I use 89 in mine my car runs like a bag of rocks, starts and stalls has no power, once I put in 91 she runs like a charm.

Well you are mistaken. You are referring to the throttle stop.
Screw on top of TB controls air flow which in turn controls idle so call it what you want idle/air control screw... Same difference

_________________
Work Log: http://mx-3.com/phpBB3/viewtopic.php?f=46&t=80716


January 30 2014, 2:40 PM
Profile
Regular Member
User avatar

Joined: June 21 2010, 1:27 PM
Posts: 542
Location: Picton
Reply with quote
Post Re: KLZE swap, some issues off the bat
yea I have used the screw on TB to help with idle, but I have never just used that screw to set idle. I've always jumped TEN & GND hooked up my tech meter on the coil or spark plug wire, set the idle with the throttle stop screw which is where you would want it to be when you let off the gas pedal. and I turned the air screw 1-2 turns I believe then pulled jumper out and works fine. but we all have our own ways.

_________________
Own
1994 MX-3 GS swapped ZE
1994 MX-3 GS Swapped ZE (Gone)
1996 Dodge Dakota Sport v8 Magnum
2007 Ford Fusion SE

WORK LOG: viewtopic.php?f=46&t=81232
Image

My MX-3 is nothing without me, and i am nothing without my MX-3


January 30 2014, 3:09 PM
Profile YIM WWW
Regular Member

Joined: March 07 2013, 9:50 PM
Posts: 70
Reply with quote
Post Re: KLZE swap, some issues off the bat
Well, she's wanting to hold idle more and more. Now it fights when it's choking instead of just giving up, so that's an improvement.

When she's running down the road she purrs like a cat, when she's sitting there she gags like a whore.

The other thing, I am running Colt N/A tri-flows... not that it changes anything (I think) but I didn't know if maybe I should try 91... the only thing that fucks with my thought on that is... it purred on 8 month old 87. Other than that all my mods are bolt on. Cold air, light flywheel, pheno spacers, pacesetters out the back. I have a new fuel filter and am suspecting that more and more, so I will change it this week.

I put half a bottle of Iso-HEET in it to try to burn up any water in the tank, seemed to help marginally. There was less than half a tank and I used half the bottle, more than enough. Smells good.

Can't be a plugged cat... don't have one :lol:

_________________
92 MX-3 ZE "The draggin' wagon"
Colt cams and bolt-ons


January 30 2014, 9:36 PM
Profile
Regular Member
User avatar

Joined: June 21 2010, 1:27 PM
Posts: 542
Location: Picton
Reply with quote
Post Re: KLZE swap, some issues off the bat
It could be fuel related have you checked fuel pressure? The only thing I can think of that would have to do with your cams would be timing. But like I said earlier if I put 89 in my ze I cant get any power out of her or keep her running, once I put 91 couldnt ask for a better ride.

_________________
Own
1994 MX-3 GS swapped ZE
1994 MX-3 GS Swapped ZE (Gone)
1996 Dodge Dakota Sport v8 Magnum
2007 Ford Fusion SE

WORK LOG: viewtopic.php?f=46&t=81232
Image

My MX-3 is nothing without me, and i am nothing without my MX-3


January 30 2014, 11:29 PM
Profile YIM WWW
Regular Member

Joined: March 07 2013, 9:50 PM
Posts: 70
Reply with quote
Post Re: KLZE swap, some issues off the bat
I will try that. If I pay 10 more cents a gallon then so be it.

Also, any dynos or drags with your ZE?

_________________
92 MX-3 ZE "The draggin' wagon"
Colt cams and bolt-ons


January 31 2014, 12:44 AM
Profile
Regular Member
User avatar

Joined: June 21 2010, 1:27 PM
Posts: 542
Location: Picton
Reply with quote
Post Re: KLZE swap, some issues off the bat
No dynos yet. I have done a couple drags about 3 years ago. Havent had the option to be able to go to drags. Not sure the times, but ive dragged against a H22 honda prelude, 73 corvette sting ray. Smacked the h22, the corvette was a tie.

_________________
Own
1994 MX-3 GS swapped ZE
1994 MX-3 GS Swapped ZE (Gone)
1996 Dodge Dakota Sport v8 Magnum
2007 Ford Fusion SE

WORK LOG: viewtopic.php?f=46&t=81232
Image

My MX-3 is nothing without me, and i am nothing without my MX-3


January 31 2014, 2:28 AM
Profile YIM WWW
Display posts from previous:  Sort by  
Reply to topic   [ 31 posts ]  Go to page 1, 2, 3  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.